Golang analyzer not reporting any errors

I have had the go analyzer running on a repository for quite a while, but suddenly it has stopped reporting any issues.
On every PR it says the there where no issues, even though I’ve found issues in the code that the analyzer should find.

There is a warning telling me that Dependency installation failed:

Dependency installation failed. It happens when SSH access to a private dependency is not configured, or when a dependency is not available. Autofix may fail unless this is fixed. To configure SSH access to private dependencies, please read Login - DeepSource.

But I don’t have any private dependencies in my project. All modules are public.
The link that it refer to is also broken.

I’ve tried to re-add the .deepsource.toml file, but that did not help. I also tried to upgrade to go 1.22 in my go.mod file, but that does not make any difference.
Any suggestions to what I can try next?

Hey @kurtinge, this issue has been fixed.

Great. I can confirm that it seems to be working again now. Thanks!

1 Like